Creating aircraft windows and window cutouts in FSDS 2.0

Comments

Transcription

Creating aircraft windows and window cutouts in FSDS 2.0
Creating aircraft windows and window cutouts in FSDS 2.0
David Eckert - www.daviator.com
The tutorial is a step-by-step guide to creating window cutouts for FSDS 2.0 models. I will be the first to admit
that Gmax does the far faster that FSDS. However keep in mind that FSDS does other things must faster and
easier than Gmax and therefore this is a trade-off.
For this tutorial I have created a generic fuselage with compound curves and a window that contains both
straight and curved areas.
Before proceeding here are a few things to know:
• Once you’ve cut your window you can no longer add cross sections to your fuselage.
• Be sure that it is as accurate as possible and back it up before proceeding.
(Part > Save…)
• I will show how to add section both fore and aft of your window area.
• This process is slow and time consuming initially, however with practice you can speed it up
considerably.
1) Switch to Side view and zoom in to fill the screen with your window shape. Notice this window has both
straight and curved areas.
Also notice that this window spans two cross sections several sections.
2) To make the window cutout we will need to create a tube along the X axis.
Before creating the tube, count the number of sections that you feel you will need to create your window.
I have calculated this window to have 15 (count Points below)
However, this creates a problem. While the window may appear to have flat areas, since they cross over
sections the flat areas are indeed curved.
Therefore we need to add points to our tube to account for the added crossed sections.
TIP: Use existing points wherever possible. This will help to keep the shape of the fuselage intact.
3) By using existing points and accounting for cross over sections I have revised my section count to 20.
Be sure one or both ends are closed.
I have now shaped the tube from the Side view ONLY to fit the shape of the window including the cross over
sections.
4) Scale the window tube along the X axis ONLY so it protrudes outside of the fuselage. Be sure at least one
end is closed. Make is a material color that contrasts with the fuselage part you wish to cut. I find red works
well.
TIP: Do NOT add polygon smoothing to the window tube at this time.
4) Next move the points along the X axis only until they just breach the outside of the fuselage.
TIPS:
•
•
to protect unwanted movement in those directions.
Use the Constrain Y and Z buttons
Do only one side at a time. I will show how to easily add the window to the other side later in this
tutorial.
•
Hide the points for the end of the tube not affected. (Switch to Point mode
and select the points you
wish to hide and go to Edit > Hide Selected.)
Use the mouse initially to move the points into position. The next section explains how to “fine tune”
the points positions.
•
5) Once you have the points close the fuselage surface it’s time to get them as close as you can.
TIP: The closer you get to the same plane as the fuselage polygons the smoother it will be.
Next we’ll move the points into place using the Shift + arrow key function.
TIP: Go to File > Project Properties and set the Scale to .001. This gives the least amount of movement when
moving the points with the shift + arrow key function.
Select any point and zoom in as close as possible. Right-click on the point in the Side view and choose Center.
Repeat for the Top and Back views.
This will also center the area you are working on in the 3D window.
Zoom in as close as possible to still see the window tube and fuselage surface in the 3D window.
TIP: When the Solid View Control window is selected, using the right arrow on your keyboard zooms in and
the left arrow zooms out.
6) Be sure that the Back view is selected and use the Shift + Left (or Right) arrow key to move the point until it
as flush as possible to the fuselage surface.
NOTE: The Constrain buttons do NOT work when using the Shift + arrow key function. So be sure that you are
in the correct window when attempting to move points with this method.
7) Repeat for all points until you just have a faint outline of the window.
TIP: use Edit > Snap to Nearest Vertex when one point from the window overlaps one for the fuselage.
To use the function, in Point mode go to Edit > Unselect all. Use your arrow keys to select the point on the
window tube you wish to snap to the nearest vertex (point) on the fuselage part.
Example of a point (white point) that was snapped to nearest vertex.
8) The next step is to combine window tube with the fuselage.
Preparation for joining the parts.
First go to Edit > Unhide All to unhide the points hidden in the TIPS section in Step 4.
Next delete the points that were previously hidden on the window tube.
Next delete the polygon face of the window tube.
Save the fuselage part if you haven’t already.
Save the window part.
9) With the window part selected, switch to Part mode and hit Shift +S on your keyboard. This will select the
window part. .
NOTE: Since you have removed all polygons from the window part you will not see the part (only it’s axis)
when switching back to part mode.
Use your arrow keys to move to the fuselage part. Hit Shift + S again to select it.
Go to Part > Join Selected.
Switch to Point mode to see the points from the window part joined to the fuselage.
TIP: Use Part > Snap to Scale to join any points accessing the same location.
10) Next remove the polygons that overlap the points where the window is located. Use your arrow keys to
navigate to them and use the Delete key on your keyboard to remove them.
Be sure that you ONLY remove the polygons that overlap the window points.
11) The next step is to build up the window frame.
Switch to top view and go to Point mode. Select and hide the points on the opposite side of the window.
12) Switch back to side view and begin creating the polygons to recreate the window cutout. ONLY select 3
points at a time. Repeat until you have the window frame completed. Flip any inverted polygons as needed.
Making the window.
13) Copy and paste the entire fuselage part.
Delete all points except those that make up the window area. Use the same method described above to create the
window.
Create a window for the other side.
14) From the top view, remove the points opposite the newly created window frame.
15) In Part mode, copy and paste the fuselage section.
Flip it alone the X axis. (Transform > Flip > X Axis)
Remove overlapping points but leave adjoining points.
16) Join the two fuselage parts.
Go to Part > Snap to Scale to join overlapping points and remove seams.
17) Copy, paste and flip the window. Use Snap to Nearest Vertex on the outer points of the window to assure
they line up exactly with the window frame.
NOTE: This technique can be also be used for entire center sections to create rows of windows on aircraft such
as airliners.
Adding cross sections after a window cut.
So you’ve cut your windows in but now realize that you need to add more cross sections to shape the nose of
your aircraft.
Delete the front set of points from your cut fuselage.
Go to Part > Load … and load your saved fuselage section.
In Cross Section mode carefully remove the cross sections that overlap with your cut fuselage.
You can now add cross sections to the nose of your aircraft and shape as desired. When completed save the new
nose section. Then join it to the existing cut fuselage part.
Remember to use Snap to Scale to remove seams and joints.
This tutorial may not be sold, distributed, or hosted on any freeware or commercial website without the written
permission of the author. © 2004 by David Eckert - www.daviator.com

Similar documents